Required Plugins

Last Updated on

The Required Plugins section in the Jupiter Control Panel lets you install plugins and add-ons to use a drag and drop page builder and empower the theme with extra functionalities.

Installing Plugins

x
Note: Installing plugins through Jupiter Control Panel is available only from Jupiter version 5.7. If you are using an older version, you may check out this article to update the theme.

As an example, we’ll install the WPBakery Page Builder, a required plugin for Jupiter which comes bundled with the theme.

1
From WordPress left menu, go to Jupiter > Control Panel.

Installing plugins and addons - jupiter control panel menu

2
From the control panel left menu, go to Required Plugins.

3
Next to WPBakery Page Builder, click on Activate button.

4
A new pop-up window will appear, click on Continue button.

5
After a couple of seconds, a new pop-up window will appear. Click on Ok button.

6
WPBakery Page Builder is now installed and activated on your website. It will be displayed above in Active Plugins section.

x
Beware! If upon accessing Jupiter control panel > Required Plugins you are displayed with an error, read Checking server requirements article, then come back to the steps above.

 


Installing Add-ons

Add-ons are exclusive free extensions only for Jupiter theme which bring more functionality and customizations.

x
Note: At the moment, add-ons are not yet ready for production and they will be released in future version of the theme.
Was this helpful?
Previous Article:
Next Article:

Can't find what you're looking for?

Open New Ticket