#137444 Background Image (Portrait) not loading

Landing Forums Jupiter WordPress Theme Background Image (Portrait) not loading

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Sean

    I have a background image, but then another portrait image both loaded in the Page sections settings in the webpage below (it’s the blue photo in the second section). The problem is that the portrait image isn’t loading. I thought that when the screen is put into Portrait mode, that the portrait photo should automatically appear. Isn’t that correct?

    Nodari Support Team

    Hi Sean

    I used this code:

    @media handheld, only screen and (max-width: 1024px){
    #background-layer--5 {
        background-image: url(https://seanc82.sg-host.com/wp-content/uploads/2021/12/public-and-private-workers-of-canada-union-history-portrait-final.jpg) !important;
    }
    }

    In your page CSS setting and it fixed the problem šŸ˜‰

    Reagards

    Sean

    Okay, but can I ask why this isn’t working naturally? I thought it was supposed to work this way.

    Also, is there a way to make the background image shrink along with the size of the screen, so can when there’s a NON-portrait background image, it will shrink down small so that it can be seen on even a phone?

    For example, if you look at the home page at https://seanc82.sg-host.com/. The top section (with the Edge Slider) has a background image that naturally shrinks at you shrink the screen size, but when you go to https://seanc82.sg-host.com/benefit-plans and look at the top section, it doesn’t do that. The background photo stays large even through you shrink the size of the screen.

    Mohsin Al-Rabieai Support Team

    Hi Sean,

    Sorry for the delayed response. You need to enable the Responsive Images through Jupiter -> Theme Options -> Global Settings -> Site Settings and then the portrait images will work.

    Hope it helps šŸ™‚

    Bests

    Sean

    Hi Mohsin. Okay, thanks for this. But whenever I do that, all the background photos on mobile devices look really blurry, which is why I always avoid turning the Responsive Images on.

    Nodari Support Team

    Hi Sean

    Which image for example and where? I just tried the page in questions and can’t see any blurry images, probably missing something

    Regards

    Sean

    Hi Nodari,

    When I enable Responsive images, they look blurry on a mobile, that’s why I turn it off, so they look clear.

    Nodari Support Team

    Hi Sean

    Yes, I understand, I just tried it but unfortunately, I really can’t see any noticeable difference, can you please tell me the steps to replicate this problem? I will temporary enable Responsive images

    Regards

    Sean

    Hi Nodari,

    When I had Responsive Images on, it just makes background photos on mobiles blurry. When it’s off, it look clear.

    What, exactly, does keeping Responsive Images on supposed to do? Thanks.

    Nodari Support Team

    Hi Sean, I understand your problem, but when I tried it I was not able to replicate it, I need to know the exact place where this is happening, screenshot as well if possible.
    Please note, when you enable responsive mode you need to use portrait images.

    Regards

    Sean

    So just to confirm, in order for the Responsive Images mode to work, you need to use portrait images, is that correct? I only ask since the blurriness was with normal size background images.

    Nodari Support Team

    Hi Sean

    ” in order for the Responsive Images mode to work, you need to use portrait images, is that correct?” – Yes, you are absolutely right, that’s correct and if you have any problem with this just show me what and where to check, I tried it on my test site, tried it on your website days ago and I was not able to reproduce the problem šŸ™‚

    With best wishes

Viewing 12 posts - 1 through 12 (of 12 total)
You must be logged in to reply to this topic.
Login