#130134 Captcha not working!

Landing Forums Jupiter WordPress Theme Captcha not working!

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • Dhiraj Website

    Hi, my Captcha isn’t working on my contact page, I have spoken to my hosting service (blue host), they played around for 15 mins and couldn’t resolve it and sent me the message below. I also saw another thread about this issue, where one of your team suggested it may be a security issue, I spoke to a security consultant I hired previously, and they assured me that it wasn’t related to the work he had done previously.

    This is what support at Blue host said:

     

    “<span style=”font-weight: 400;”>I have updated the file permission to CHMOD 755 and also updated PHP and WordPress version, but still it shows same. I have checked the issue in the server-side and unable to see any error or issue from server-side. Errorlog says issue is with the plugin artbees-captcha . Please contact plugin vendor and get the updated version of the plugin and then contact us with new server requirements of that plugin so that we can update it for you and issue will be resolved.”</span>

    I have also attached a screenshot. ignore the Matrix, that was an accident and couldnt see how to delete it. Apologies!

    Dhiraj Website

    Hi here is the appropriate screenshot. i couldn’t delete the wrong one! Thanks!

    Nodari Support Team

    Hi Dhiraj

    Please check this link of documentation: https://themes.artbees.net/faq/captcha-not-showing/ you have exact same problem on your website: https://prnt.sc/1qv3inn you need to get back to your hosting and ask them to verify this issue again,

    Regards

    Dhiraj Website

    Hi Sorry exactly what should I say to them, because they already looked and couldn’t find it. So I assume they don’t even know where to look. If you could help me guide them to the relevant issue that would be great!

    Dhiraj Website

    Also if it helps,

    So i previously read your Captcha issue page and found that i had the 403 error by using inspect element (see attachment).

    I then when through the process it suggest, checking out that the appropriate folder had the 755 permission (see screen shot)

    I then proceded to ask Bluehost as you suggest and told them the process i had been through. And that’s when they spent 15 mins, and did everything they said in their message, and told me to go back to you guys.

    So if you could help me with what i need to say to them, that would be great! Thanks.

    Dhiraj Website

    Captcha permissions screenshot.

    Dhiraj Website

    Thanks Nodarl, for the help so far!

    Tatyana Hutsol Support Team

    Hello,

     

    I tried to log in to Bluehost, but got the error “Login Failed”.

    Could you please re-check the credentials?

     

    Regards.

    Private
    Dhiraj Website
    This reply has been marked as private.
    Dhiraj Website

    Just checked that updated password Tatyana, it definitely works.

    Thanks!

    Tatyana Hutsol Support Team

    Hello,

    The issue was caused by the rule in the main .htaccess file in line 269. I’ve commented it to fix the captcha displaying.

    Please check the contact form now.

     

    Regards.

    Dhiraj Website

    Hi Tatyana, thanks for this! I checked on my end on 2 different browsers and 2 different devices i still have the exact same issue as before as shown in the origional screenshot! Is it fixed when you look at it?

    thanks!

    Dhiraj Website

    I know this is tedious so i really appreciate your persistence!

    Alexander Hutsol Support Team

    Hello,

    I found that the restriction rules are added to the .htaccess file via the iThemes Security plugin settings https://i.imgur.com/atNvMmi.png , so the file was automatically overwritten after some time, that’s why you saw the error with captcha when checking it from your side.

    I turned off the Disable PHP in Plugins option in the plugin settings https://i.imgur.com/fogwp5E.png so now the captcha is displayed as it should https://i.imgur.com/ZQRRkmx.png

    Please check the contact page now and let us know if our assistance is still needed.

     

    Regards.

    Dhiraj Website

    You guys are geniuses! Well done, thank you for the help.

    Does it sound like something that is likely to happen again, for example when Ithemes security gets updated?

    If so could you perhaps just send me a screenshot of the code where I might need to change it again in the future, or perhaps some instructions so that I don’t have to pester you guys again if it happens!

    Thanks!

    Alexander Hutsol Support Team

    You are welcome 🙂

    I think it won’t happen again as the last time changes were made via the plugin settings, but not manually in the .htaccess file as it was before. Just in case, the mentioned plugin settings can be found in the WP Dashboard > Security > Settings > Advanced section as shown on the screenshot https://i.imgur.com/lptvQQE.png

     

    Regards.

    Dhiraj Website

    Thanks Alexander!

    Alexander Hutsol Support Team

    Hello,

    You are welcome 🙂

    Feel free to create a new topic if you have any other questions.

     

    Regards.

Viewing 18 posts - 1 through 18 (of 18 total)
You must be logged in to reply to this topic.
Login