#133564 Conflict between Jupiter X Theme and WooCommerce Plugin

Landing Forums JupiterX WordPress Theme Conflict between Jupiter X Theme and WooCommerce Plugin

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • sophia.boddin-daff1f4a

    Hello,

    i have a problem reaching my homepage/startpage in wordress. Whenever i want to edit the page, the following message appears: “There has been a critical error on this website please check your site admin email.”

    I have come to the conclusion, that it’s a conflict with woocommerce after deinstalling all plugins and than installing them again one by one. Only after installing woocommerce the problem appears. I do can edit other pages like “Sets” or “About”.

    Do you have any idea what could be the problem here?

    Kind regards

    Sophia Boddin

    Mohsin Al-Rabieai Support Team

    Hi Sophia,

    Sorry for the delayed response. I was trying to enable the debug mode on your website to be able to see the issue. However, it seems like your web host has disabled any kind of error logging or error display is off. Currently, there is no way I can see the error so the following would be blind advice. You need to contact your web host and ask to enable error logs or allow you to do so and after that, we can see what the issue is.

    You have 16 WooCommerce dependent plugins that won’t run (although they are active) until WooCommerce is activated. I believe WooCommerce itself won’t cause issues like this, but a dependent plugin (one of those 16) could be the reason. I wanted to deactivate the plugins one by one but I realized it’s a live website so need to grant your permission to do so. In general, it’s better to use a staging website (a duplicated version of the website for debugging purposes) and we do all the debugging on the staging website.

    Best regards

    sophia.boddin-daff1f4a

    Hey Mohsin!

    You have every permission, to try the plugins too! I will also check at the hoster to enable the error logs.

    Thanks allready!

    Best regards

    Sophia

    sophia.boddin-daff1f4a

    Ok, i can actually see the ERROR Logs through my Hosting Account. This is what it says:

     

    [Sun Oct 17 01:40:52 2021] [ssl:warn] [pid 3685] [client [host AH01909: landbeck-keramik.de:443:0 server certificate does NOT include an ID which matches the server name
    [Sun Oct 17 15:34:14 2021] [access_compat:error] [pid 9896] [client 5.175.14.28] [host landbeck-keramik.de] AH01797: client denied by server configuration: /is/htdocs/wp1038008_RTM4FZUPI4/www/landbeck/wp-content/uploads/woocommerce_uploads/
    [Sun Oct 17 18:33:01 2021] [ssl:warn] [pid 3685] [client [host AH01909: landbeck-keramik.de:443:0 server certificate does NOT include an ID which matches the server name
    [Sun Oct 17 18:33:47 2021] [ssl:warn] [pid 3685] [client [host AH01909: landbeck-keramik.de:443:0 server certificate does NOT include an ID which matches the server name
    [Sun Oct 17 18:34:38 2021] [ssl:warn] [pid 3685] [client [host AH01909: landbeck-keramik.de:443:0 server certificate does NOT include an ID which matches the server name
    

     

    Does this help you? Also, the configuration i made in the wp-config file (see screenshot) are correct right? Or do they cause the issue that you couldn‚Äėt see the errorr logs?

    Thanks in advance!!

    Sophia

    Mohsin Al-Rabieai Support Team

    Hi Sophia,

    Ok it seems like there are too many post revisions on the homepage (926 revisions). I installed a phpMyAdmin plugin, and manually changed the post_parent field on the wp_posts on your database on those records that the ID was the same as your homepage. It resolved the issue on the homepage.

    I actually didn’t remove the revisions and replaced the post_parent ID of those records with something else. It will take the revisions out of the homepage, however, they still exist. It is highly recommended to clear all the revisions using the WP-Optimize plugin. This would resolve the issue on your website.

    It was a DB issue after all.

    Bests

    sophia.boddin-daff1f4a

    Hello and thanks a lot for your support!

    I understand the issue better now and cleared the revisions by using the recommended plugin.Unfortunately now i can’t edit any page in elementor anymore. The Page won’t stop loading (see screenshot). I tried clearing the browser cache and different browsers already… doesnt’t help.

    Do you know what could have caused this issue?

    Thanks and kind regards

    Sophia

     

    Mohsin Al-Rabieai Support Team

    Hi Sophia,

    I could see the issue and realized that it happens due to server resource limitations. I went through the Jet Elements settings and deactivated the “Use Jet Templates” option and set the “Editor Load Level” to “None” and the issue is resolved now. Please check it on your website.

    Bests

    sophia.boddin-daff1f4a

    Okay, now i can edit, thanks! But the slider on the startpage is not showing correct now…

    Since i used a jet element widget here, htis solution will not work for me. Sorry but is it anything else you can do here?

    Best Regards

    Nodari Support Team

    Hi Sophia

    Please try again, I just added width and height values for mobile break points: https://prnt.sc/1wxqae7

    Regards

    sophia.boddin-daff1f4a

    Hello Nodari,

    thanks but that is not the problem. The Images which are set with elementor, don’t show up if you check on the website directly: https://landbeck-keramik.de/

    I really need a solution here, since this problem was only appearing since your colleague edited the Jet Elements settings.

    Thanks a lot and kind regards

    Sophia

     

    Mohsin Al-Rabieai Support Team

    Hi Sophia,

    My apologies for the inconvenience. Can you please contact your web host support and ask to increase your PHP memory limit? Apparently, it exceeds the memory limit while trying to load a couple of Jet Elements widgets. If you shut down a couple of Jet Element’s widgets through Crockoblock -> Jet Elements -> Widgets you can set the editor load to “Full” and edit the slider settings to avoid that issue (color overlay on your slides). However, it should be resolved as well if you increase the PHP memory limit too. Currently, it has a limitation of 256M and it seems to be not enough here.

    Another thing to try is to enable the “mod_substitute” on your Apache. Can you also do that and try again?

    Best regards

    sophia.boddin-daff1f4a

    Super, limitating the Jet Element Widgets worked just fine!
    Thanks for the support!

    Kind regards
    Sophia

    Amir Rather Support Team

    You’re most welcome ūüôā

Viewing 13 posts - 1 through 13 (of 13 total)
You must be logged in to reply to this topic.
Login