#78216 Custom Post Type – Jet Engine – Edit Parent Page

Landing Forums JupiterX WordPress Theme Custom Post Type – Jet Engine – Edit Parent Page

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Anup Sarode

    Hello,

    I have successfully created a custom post type called Employees (slug – employees) and have added 1 item (employee-1) to the case studies. So now I have the following URL’s

    https://my-domain.com/employees and https://my-domain.com/employees/employee-1

    I need to customize the /employees slug using Elementor. I was not able to find any info on how to do it. Maybe I’m missing something obvious.

    Help is appreciated.

    Thanks.

     

    Anup Sarode

    Update:

    So I have created a new page named Employees (slug – /employees) and I am able to edit that with Elementor.

    Now I have a new problem. I also have a blog on the website and in Permalinks I have used – /blog/%postname%/

    Because of this, I am getting the following URL’s

    https://my-domain.com/employees and https://my-domain.com/blog/employees/employee-1

    I need to remove the /blog from the employee single page URL. I think this can be done from functions.php but not sure how.

    Please help.

    Thanks,

    Anup Sarode

    Update:

    Please ignore my second comment as this approach doesn’t work. I need a solution for the first comment itself.

    Just need to know how I can edit the https://my-domain.com/employees URL with elementor.

    Thanks.

    Amir Rather Support Team

    Hi There

    If you created a Custom Post Type like this https://themes.artbees.net/docs/how-to-create-custom-post-type-in-jupiter-x/

    You can edit the Post Type Slug in Jet Engine settings, did you try that?

    Regards

    Anup Sarode

    Hello Amir,

    I have created the Custom Post type by following the mentioned tutorial. I have used Jet Engine and not CPT UI. I am still not able to edit the https://my-domain.com/employees page.

    Is any other solution possible?

    Anup Sarode

    I think has something to do with the Jet Engine -> Custom Post Types -> Rewrite (Rewrite with front) setting

    Nodari Support Team

    Hello Anup

    Sorry about that, may I take a closer look? please provide us with wp-admin login details to your site in the private reply https://prnt.sc/qr3w3e to check the issue.

    Thank you.

Viewing 7 posts - 1 through 7 (of 7 total)
You must be logged in to reply to this topic. Login