#77517 Different results in elementor editor and on preview/live page

Landing Forums Jupiter WordPress Theme Different results in elementor editor and on preview/live page

Tagged: 

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • Seymour Segnit

    Hello,

    For some reason I am getting different results on live page when I preview it than I have in Elementor editor on the page.
    This is the page: https://www.magfast.com/checkout-selector-special-event/

    This is footer in editor: https://prnt.sc/u3iwzz
    This is footer on live page: https://prnt.sc/u3ixkt

    You have to change your host file in order to access our test server which are in Website Access Credentials section.

    Thank you in advance.

    Seymour Segnit

    It looks like CSS is not behaving properly on a live/preview page.

    Seymour Segnit

    If you see preorder now button at the end, it is orange and on live page it is green, so the rule is missing.

    Amir Rather Support Team

    Hi There

    The Provided page shows 404 error https://prnt.sc/u3uqxm

    What am I missing?

    Regards

    Seymour Segnit

    Hi Amir,

    That page not exist on a live server, only on test server. You have to use provided IP address and put it in your hosts file in order to access that server.

    Regards

    Private
    Seymour Segnit
    This reply has been marked as private.
    Seymour Segnit

    Hello,

    Can anybody help me?

    Thank you

    Amir Rather Support Team

    First of all, Really sorry for the late response, we are currently experiencing an influx of tickets so our response time has increased.

    I see the Footer Like this at the moment https://prnt.sc/u78fxx

    Were you able to correct it or am I missing something?

    Regards

    Seymour Segnit

    Hi Amir,

    Can you please check this page: https://www.play.magfast.com/checkout-selector-10-sept-v1/

    Thanks

    Amir Rather Support Team

    Hi There

    I added the below CSS in Theme Options > Advanced > Custom CSS

    .elementor-element-47e27d3c .elementor-widget-heading .elementor-heading-title {
    font-size: 19px !important;
    text-align: center;
    }

    Check the footer now 🙂

    Seymour Segnit

    Hi Amir,

    Thanks for doing that but I am capable to center the text. Please read what is my problem. I will repeat the same thing from the beginning of this ticket.

    For some reason I am getting different results on live page when I preview it than I have in Elementor editor on the page.
    This is the page: https://www.play.magfast.com/checkout-selector-10-sept-v1/

    This is footer in editor: https://prnt.sc/u3iwzz
    This is footer on live page: https://prnt.sc/u3ixkt

    My problem is not why footer is not centered but why displays correctly in editor and wrongly when previewing the page .

    This is very important and I am already late with my project because this takes so long to resolve.
    Thank you in advance.

    Seymour Segnit

    Also, this does not happen on all pages.

    Alexander Hutsol Support Team

    Hello,

     

    Could you please disable all 3rd-party plugins and check the footer after that?

    Let us know the result.

     

    Thank you.

    Regards.

    Seymour Segnit

    Hi Alexander,

    I disabled all the plugins except Elementor and Elementor Pro and the issues is still there.

    I never had this issue before (for 2 years working with Elementor)

    Regards

    Tatyana Hutsol Support Team

    Hello,

     

    Sorry for a delay.

    The color values are taken from the Global settings in Elementor https://take.ms/KV2In . It was caused by a new Elementor update where they made huge changes in the code.

    You can check it in the Elementor editor > click on the burger icon at the top https://take.ms/sPopU > Site Settings > Global Colors https://take.ms/vVG4A .

    The default colors can be disabled in Elementor Settings https://take.ms/bvBmS , but in this case the styles will be applied from Theme Options https://take.ms/qEk6i > Main Content > Texts https://take.ms/DZYU6 . In this case you need set the colors in the Theme Options.

    Note that Elementor is not recommended for Jupiter 6 as the main page builder there is WPBakery, and Elementor is required in the Jupiter X theme. So, either upgrade to Jupiter X or re-create your pages with WPBakery, or change styles in Theme Options.

     

    Thank you for understanding.

    Regards.

    Seymour Segnit

    Hi Tatyana,

    I must say I am very disappointed with your answer. This is not the first time when you were not able to solve a technical issue, and when you blamed it on Jupiter 6 incompatibility with Elementor. (when I say you I refer to the support team)

    I am using Elementor and Jupiter 6 for almost 2 years successfully without any incompatibility issues and this never happened (different things showing on page edit and live page)
    You wasted  my time and energy since this ticket was posted almost 3 weeks ago and I have a problem finishing my work because of it.
    And 3 weeks is fine if the problem is resolved, but it is not, and the only response I get is that Elementor is not theme compatible which is crazy since Elementor works with almost every theme. That is what page builders do.

    I understand that there is a new Jupiter X theme but we have so much custom code implemented that it would take us months to transfer it to a new theme because of different classes, containers etc, so that is not a solution.

    We are already paying for your support and now I have to find and pay somebody else to fix this issue.

    Regards

    Tatyana Hutsol Support Team

    Hello,

     

    It might work properly before, but in Elementor v3* they changed a lot in the code:

    https://developers.elementor.com/tag/elementor-v3-0/

    https://elementor.com/blog/elementor-3-new-professional-features/

    and now even Jupiter X (where Elementor is used as the main page builder) has issues and needs to be fixed.

    You can try to roll back to the older Elementor version:

    https://docs.elementor.com/article/382-rolling-back-to-a-previous-version-of-elementor

    or it’s better to upgrade to Jupiter X (some fixes were released for new Elementor).

     

    Thank you for understanding.

    Regards.

    Seymour Segnit

    Hi Tatyana,

    Thank you for you answer and it sound reasonable.
    Are you planing to work on Jupiter 6 to make it compatible with new Elementor?

    Regards

    Tatyana Hutsol Support Team

    Hello,

     

    Unfortunately there is no such plans, our developers are working to make Jupiter X compatible with Elementor, and Jupiter 6 will be compatible with WPBakery Page Builder as this is the main plugin to create pages in Jupiter 6.

     

    Thank you for understanding.

    Regards.

    Ayman dev

    I am currently experiencing the same issue. When I edit on elementor, I can see all my changes perfectly but once it’s pushed live or even in preview mode, it shows in a completely different way. I have purged the cache, disabled plugins, re generated CSS files for Elementor and the issue still persists. Any help would be appreciated.

    Tatyana Hutsol Support Team

    Hello @Ayman,

     

    Are you using the latest WP version?

    They removed jquery support and it might cause the issue.

    Try to install the plugin https://wordpress.org/plugins/enable-jquery-migrate-helper/ and check the site.

    If the issue still persists, please provide WP Dashboard credentials in the private reply.

     

    Thank you.

    Regards.

Viewing 21 posts - 1 through 21 (of 21 total)
You must be logged in to reply to this topic. Login