#42552 Editing page?

Landing Forums JupiterX WordPress Theme Editing page?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • Wee J. J.

    Hi there,

    This seems like a pretty stupid issue, but I have problems just editing the page itself. I’ve been using Jupiter for over 4 years now and I’ve only just decided to try out the new Jupiter X. I know how to use both Elementor and WPBakery. When I imported the “The Lawyer” template, I find myself unable to use both page builders at all: (1) I am not given an option to edit the page with Elementor, and (2) at the backend, the regular WPBakery Builder is not working, and all I get is an odd WordPress-default text-based stuff.

    I thought it’s a problem with my import, and I deactivated WPBakery and reimported the template but I am still faced with the same issue of not being able to use both Elementor and WPBakery to edit the page. Could you let me know how I can actually edit pages on Jupiter X templates?

    Your long-time customer


    Hi Wee

    First of all, I just activated Wpbacker page builder and its loading well on your pages, there is no problem to use it for pages

    Well, the important thing in this situation is that everything in Jupiter X (Posts, pages, products etc) are build by Elementor, so, you cant edit them by Wpbacker page builder, this attempt will fail for sure, however, you can create new pages from scratch and build them by using Wpbackery page builder, there is no problem with this

    Wee J. J.

    Hi Nodari,

    Thanks for looking into this. I know Jupiter X uses Elementor, so I was a little confused when I am not able to edit my pages using Elementor. I don’t want to use WPBakery as well.

    Could you see the screenshot where I do not have the option to edit the page, but just the headers and the footer? How can I edit the page as per Elementor?

    Wee J. J.

    To be more specific, I’m unable to click on “Edit with Elementor”, which, according to my understanding, is how we activate the Elementor page builder.



    Thank you for clarification, I just fixed it, and you will be able now to use Elementor for the homepage and for any other page.

    I just enabled Elementor for pages in Elemenot > Settings > and on this page, I just selected checkmark for Pages and saved ūüôā

    Please check and let me know if it’s working

Viewing 5 posts - 1 through 5 (of 5 total)
You must be logged in to reply to this topic.