#128559 Elementor not working with woocommerce

Landing Forums JupiterX WordPress Theme Elementor not working with woocommerce

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • Daniyal Haider

    Hi,

    I have figured out that elementor is not working when woocommerce is activated, elementor shows 403 error while loading up.

    Need help.

    Nodari Support Team

    Hi Daniyal

    Thank you for contacting us, please provide access details in a PRIVATE reply here and steps to replicate your problem, I will check why it’s not working and will try to fix it

    Best wishes

    Private
    Daniyal Haider
    This reply has been marked as private.
    Private
    Nodari Support Team
    This reply has been marked as private.
    Private
    Daniyal Haider
    This reply has been marked as private.
    Nodari Support Team

    Yes, I understand but the hosting or Cloudflare setup is very unstable, I can’t debug the problem due to this problem which appears every minute: https://prnt.sc/1mp9dit this problem also might be the root of the problem, can you please resolve it?

    Thanks in advance, waiting for your reply

    Daniyal Haider

    i cant see the screenshots. can you send the screenshots through another way

    even the previous screenshot is not working.

    Private
    Daniyal Haider
    This reply has been marked as private.
    Private
    Nodari Support Team
    This reply has been marked as private.
    Daniyal Haider

    Hi,

    So i changed the DNS and now I am not using Cloudflare. I directly attach the domain with Plesk Web Admin.

    But the issue is the same.
    now I am reinstalling it completely and then I will check either it is working or not.

    Private
    Daniyal Haider
    This reply has been marked as private.
    Nodari Support Team

    Hi Daniyal

    So sorry about this, yes, I confirm the site is working fine without a JetWoobuilder, after another review I was not able to find the main problem so I’m sending this ticket to the supervisor, please be aware it will be reviewed on Sunday, meanwhile you may continue using your site without a JetWoobuilder.
    JetWoobuilder plugin is only necessary if you are customizing Woocmmerce store and pages, so, if you are not going to use those features you may ignore that plugin at all

    Let me know if you have anything else and sorry for inconvenience

    Best wishes

    Daniyal Haider

    Yes, I do need assistance with that.
    I am working on an e-commerce store and I will do the rest work in the meanwhile.
    I was also thinking to change the company as well. I am using Vultr Cloud Compute and I am thinking to go to Digital Ocean because they have a different way of DNS connection.

    But I am waiting for your team’s review. if the solution will be derived then I will not change the system.

    Nodari Support Team

    Thanks for understanding Daniyal, my colleague will review your ticket for tomorrow, Sunday, thanks for your patience.
    Yes of course, this is not the reason to stop working on the site 🙂

    Best wishes

    Private
    Daniyal Haider
    This reply has been marked as private.
    Private
    Daniyal Haider
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi Daniyal,

    This is Mohsin stepping in for Nodari. As far as I can see, the errors are related to the mod_security in your Apache settings. I believe, to make sure this issue is related to mod_security, you can ask your web host support to temporarily deactivate it for you and then you can test the Elementor with Jet Woo Builder. Unfortunately, deactivating the mod_security is out of reach for us and you need to ask it from your web host support for sure.

    Bests

    Daniyal Haider

    Hi Mohsin,

    Basically, I am using Vultr with Plesk installed on it and I have the access.
    let me change the settings and then I will get back to you.

    Daniyal Haider

    Yes, it worked when I turned off the ModSecurity from the settings.
    I activated the Jet WooBuilder and now the elementor editor is working.

    But now the Website firewall is off. as I attached the screenshot.
    i have also attached the screenshot of the Rules setup for the firewall.

    Daniyal Haider

    So i tested and it worked with this rule set “OWASP (free) running on Apache (ModSecurity 2.9)”

    now I will work on the site in case if I encounter any error I will inform you.

    Mohsin Al-Rabieai Support Team

    Thanks, I guess your web host can help you provide some exceptions for jet woo builder scripts to run with mod_security as well.

    Anyway, glad that the issue is resolved. 🙂

Viewing 21 posts - 1 through 21 (of 21 total)
You must be logged in to reply to this topic.
Login