#76406 Fullwidth slideshow doesn’t show images anymore.

Landing Forums Jupiter WordPress Theme Fullwidth slideshow doesn’t show images anymore.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • X-06 Designs

    I didn’t got the notification not to update to WordPress 5.5, so I have the following problem now: after updating, the fullwidth slideshow element of WP Bakery page builder doesn’t show images anymore. I checked it with the developer console of my browser and the html element said that there’s no image source.

    Can you please check that issue?

    https://main-maeuerle.de/

    I deactivated the row with the fullwidth slideshow. If you want to check the error, you need to activate it again.

    Caorda Support

    Try installing this plugin.  The newest version of WordPress disabled jQuery migrate and this enables it again.

    Amir Rather Support Team

    Since WP version 5.5, WordPress has removed support for <b data-stringify-type=”bold”>jQuery migrate</b> and I suspect the issue is related to that. To address this issue, WordPress has released a plugin, please install this plugin https://wordpress.org/plugins/enable-jquery-migrate-helper/ and see if this helps?

    Waiting for your reply 🙂

    X-06 Designs

    Unfortunately installing the plugin didn’t work. I still cant see the images and only see the meta titles.

    Amir Rather Support Team

    Hi There

    I tried logging in to investigate but it’s giving 503 services unavailable error screenshot

    Am I missing something?

    Regards

    X-06 Designs

    Could you please try it again? The WP login page loads normally (checked it on multiple devices)

    Alexander Support Team

    Hello,

     

    Thank you, I was able to log in.

    Could you please also provide FTP credentials to investigate the issue?

     

    Thank you.

    Regards.

    Private
    X-06 Designs
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi there,

    Please accept my sincere apologies for the delayed response. It’s actually a bug in the recent version of Donut and you discovered it! Thanks for reporting it. I have escalated this to our developers and soon the fix will be included in the next versions of Dount. However, as a temporary fix, I changed jupiter-donut/includes/helpers/general-functions.php line 430 from this:

    	function mk_get_wpml_media( $media_url = false, $media_id = false, $return = 'url' ) {
    		$enable = apply_filters( 'jupiter_donut_wpml_media_translation', true );
    
    		if ( ! $enable || ! function_exists( 'icl_object_id' ) ) {
    			return $media_url;
    		}
    
    		if ( ! empty( $media_url ) && empty( $media_id ) ) {
    			$media_id = attachment_url_to_postid( $media_url );
    		}
    
    		$media_id_translated = icl_object_id( $media_id, 'attachment', false, ICL_LANGUAGE_CODE );
    
    		if ( 'id' === $return ) {
    			return $media_id_translated;
    		}
    
    		// If translated media id exists.
    		if ( empty( $media_id_translated ) ) {
    			return $media_url;
    		}
    
    		// If translated media url doesn't exists.
    		if ( $media_url_translated = wp_get_attachment_url( $media_id_translated ) ) {
    			$media_url = $media_url_translated;
    		}
    
    		return $media_url;
    	}
    }

    To this:

    	function mk_get_wpml_media( $media_url = false, $media_id = false, $return = 'url' ) {
    		$enable = apply_filters( 'jupiter_donut_wpml_media_translation', true );
    		
    		if ( ! $enable || ! function_exists( 'icl_object_id' ) ) {
    			if(  empty( $media_url ) && !empty( $media_id ) )
    			{
    				return wp_get_attachment_url ($media_id);
    			}
    			else {
    				return $media_url;
    			}
    			
    		}
    
    		if ( ! empty( $media_url ) && empty( $media_id ) ) {
    			$media_id = attachment_url_to_postid( $media_url );
    		}
    
    		$media_id_translated = icl_object_id( $media_id, 'attachment', false, ICL_LANGUAGE_CODE );
    
    		if ( 'id' === $return ) {
    			return $media_id_translated;
    		}
    
    		// If translated media id exists.
    		if ( empty( $media_id_translated ) ) {
    			return $media_url;
    		}
    
    		// If translated media url doesn't exists.
    		if ( $media_url_translated = wp_get_attachment_url( $media_id_translated ) ) {
    			$media_url = $media_url_translated;
    		}
    
    		return $media_url;
    	}
    }

    And the issue is now resolved. Thanks for your patience and collaboration.

    Bests

    X-06 Designs

    Awesome, thank you very much for the quick fix!

    I also encountered a problem with updating WP Backery (modified version) to v 6.3. The update is shown in the WordPress update-section, but I’m not able to update the plugin.

    Mohsin Al-Rabieai Support Team

    The latest version of the WPBakery Modified version is currently 6.2 in our plugins repository. Once we made sure that the 6.3 updates won’t harm anything we will update it in our repository and then it would be possible to update. Thanks for your understanding.

    Carel van der Wyck

    Hi,

    I think I have the same problem after updating everything to the latest versions at https://www.valkdesign.nl/visuals/

    Where can I find this file:
    jupiter-donut/includes/helpers/general-functions.php ?

     

    Regards, Carel

    Alexander Support Team

    Hello @Carel van der Wyck,

    The mentioned file is located in the Jupiter Donut plugin directory which can be found in the wp-content/plugins folder.

     

    Regards.

Viewing 13 posts - 1 through 13 (of 13 total)
You must be logged in to reply to this topic. Login