#128435 header footer not showing on product page

Landing Forums JupiterX WordPress Theme header footer not showing on product page

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • faiq ali
    Alexander Hutsol Support Team

    Hello,

     

    Were header and footer shown before?

    Could you provide FTP credentials in the private reply for investigation?

     

    Regards.

    Private
    faiq ali
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

     

    Thank you.

    I tried to reupload theme files, but got an error:

    open for write: permission denied
    Error: File transfer failed

    Seems it’s because of the root user that is set for the files.

    Can you allow access to upload/edit the file via FTP.

    Looking forward to your reply.

    Regards.

     

    Private
    faiq ali
    This reply has been marked as private.
    Private
    Alexander Hutsol Support Team
    This reply has been marked as private.
    Private
    faiq ali
    This reply has been marked as private.
    Private
    faiq ali
    This reply has been marked as private.
    Private
    faiq ali
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

    We’re debugging the issue and it will take some time. We will let you know about the results in this thread.

    Thank you.

     

    Regards.

    Mohsin Al-Rabieai Support Team

    Hi Faiq,

    The issue with the product page not showing the header and footer is something related to the Database. I checked all possible corners and realized that the customizer settings are no longer being saved in the database. Rather than this, I found no other issues. The reason might be a corrupted data while updating something. In order to resolve this, I highly recommend you reset your customizer settings using the plugin “Customizer Reset” (you can download and activate it through the WordPress Plugins pane or from Jupiter X -> Control Panel -> Plugins). Unfortunately, after that, you need to reconfigure the styling option, header and footer settings, and all the customizer settings.

    Since the data is already corrupted I don’t want to take a risk and touch anything without your permission. I can take a backup of the customizer settings using the “Customizer Export/Import” plugin, but there is a chance that the import won’t complete correctly because of some corrupted data.

    Best regards

    Private
    faiq ali
    This reply has been marked as private.
    Private
    faiq ali
    This reply has been marked as private.
    Private
    faiq ali
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

     

    Ok, let us know if the issue happens again after reinstallation.

     

    Thank you.

    Regards.

    Private
    faiq ali
    This reply has been marked as private.
    Private
    faiq ali
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi there,

    I debugged the issue on your website and realized that you have a truly big header template. If you use the default header template and check again with GTMetrix, your TTFB is 500 ms, while if you use the custom header, your TTFB is 3.5 seconds. This means that you are using lots of widgets and inner sections inside your header template. If you use a lighter header template, you won’t have any issues.

    Anyway, since this is a huge header, it may end up with some resource limitations on your web host. Web hosts that are not WordPress optimized are usually had such problems. I strongly recommend you switch to a WordPress-optimized web host to avoid such issues.

    Also, please avoid using multiple plugins with the same job. It reduces your website performance. In general, better to follow up with the guidelines mentioned here to have a performant website:

    Best regards

Viewing 18 posts - 1 through 18 (of 18 total)
You must be logged in to reply to this topic.
Login