#134993 Juper X Core requires Elementor Pro Pages to be in Safe Mode

Landing Forums JupiterX WordPress Theme Juper X Core requires Elementor Pro Pages to be in Safe Mode

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • martin_russell-4da143b4

    Hi
    I’ve a two issues with Jupiter X Theme which I’ve just bought:

    1. Soon after I activate the Jupiter X theme I get  a “Critical error on this website” error with the home page. The log gives:

      Uncaught Error: Class ‘WP_Customize_Control’ not found in /home/u653744124/domains/…/public_html/wp-content/plugins/jupiterx-core/includes/customizer/api/includes/base/class-control.php:26
      Stack trace:
      #0 /home/u653744124/domains/…/public_html/wp-content/plugins/jupiterx-core/includes/customizer/api/includes/class-autoloader.php(81): include_once()
      #1 [internal function]: JupiterX_Core_Customizer_Autoloader->autoload(‘JupiterX_Custom…’)
      #2 /home/u653744124/domains/…/public_html/wp-content/plugins/jupiterx-core/includes/customizer/api/includes/base/class-input-group.php(24): spl_autoload_call(‘JupiterX_Custom…’)
      #3 /home/u653744124/domains/…/public_html/wp-content/plugins/jupiterx-core/includes/customizer/api/includes/class-autoloader.php(81): include_once(‘/home/u65374412…’)
      #4 [internal function]: JupiterX_Core_Customizer_Autoloader->autoload(‘JupiterX_Custom…’)
      #5 /home/u653744124/domains/…/public_html/wp-

    2. If I switch to another theme, this error goes away, but with Jupiter X Core activated, Elementor Pro is going into Safe Mode on all pages – even if I swap the Theme from Jupiter X.

    When I disable the Core plugin, all is well. I didn’t buy Jupiter X as a replacement for Elementor Pro, but as an addition – since I’ve
    developed the site using Elementor Pro and obviously paid  for the license.

    Since I’ve seen reference to the Transients Manager in places I’ve installed that plug-in and deleted all Jupiter X transients, but left the others. That hasn’t changed anything.

    Short of throwing away what I’ve done, reinstalling the backup and starting all over again, I’m not such what I should do.

    I couldn’t pre-test Jupiter X, only Jupiter lite – so I never saw these problems until after I’d purchased the theme 🙁

    Thanks in advance
    Martin

    Amir Rather Support Team

    Apologies for the inconvenience,

    Please kindly provide WP Login and (in private reply) FTP Login details so we could investigate the issue and try to resolve it.

    Waiting for your reply 🙂
    Thank you in anticipation.

    Private
    martin_russell-4da143b4
    This reply has been marked as private.
    Amir Rather Support Team

    Hello there

    Strangely, when I put the login details here https://new.connectingart.ch/sign-in/ and click login nothing happens.

    What am I missing?

    Regards

    martin_russell-4da143b4

    Please try again

    martin_russell-4da143b4

    I’ve reset your password to be the same as I posted above. I’ve tested & it certainly works OK for me.

    Mohsin Al-Rabieai Support Team

    Hi Martin,

    You need to keep the “Kirki Framework Customizer” plugin deactivated because it has massive conflicts with Jupiter X. Jupiter X is using the same framework and having duplicated classes is causing this error.

    Bests

Viewing 7 posts - 1 through 7 (of 7 total)
You must be logged in to reply to this topic.
Login