#126038 Jupiter X Core error when attempting to edit CartFlows pages with Elementor

Landing Forums JupiterX WordPress Theme Jupiter X Core error when attempting to edit CartFlows pages with Elementor

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • TED THOMAS

    This error only occurs when I have Jupiter X Core 1.22.2 running.  If I disable it, the error doesn’t happen.

    The only other plugins running are:

    Advanced Custom Fields 5.9.8
    Advanced Custom Fields PRO 5.9.8
    CartFlows 1.6.15
    CartFlows Pro 1.6.15
    Elementor 3.2.5
    Elementor Pro 3.3.1
    WPFusion 3.37.25
    and
    the Jupiter X theme 1.25.1

    (all on a fresh install of WordPress 5.7.2)

    I need all of them in order to edit Elementor pages through CartFlows.

    We have been running that EXACT config for more than a year but something changed about 30 days ago after the Jupiter X theme and the Jupiter X Core were both updated.

    frontend.min.js?ver=5.7.2:1 Uncaught TypeError: $ is not a function
        at Object.i.handleFullPageEditorBtn (frontend.min.js?ver=5.7.2:1)
        at e (frontend.min.js?ver=5.7.2:1)
        at dispatch (jquery.min.js?ver=3.5.1:2)
        at v.handle (jquery.min.js?ver=3.5.1:2)
        at Object.trigger (jquery.min.js?ver=3.5.1:2)
        at jquery.min.js?ver=3.5.1:2
        at Function.each (jquery.min.js?ver=3.5.1:2)
        at s.fn.init.each (jquery.min.js?ver=3.5.1:2)
        at s.fn.init.trigger (jquery.min.js?ver=3.5.1:2)
        at Frontend.init (frontend.min.js?ver=3.2.5:2)
    i.handleFullPageEditorBtn @ frontend.min.js?ver=5.7.2:1
    e @ frontend.min.js?ver=5.7.2:1
    dispatch @ jquery.min.js?ver=3.5.1:2
    v.handle @ jquery.min.js?ver=3.5.1:2
    trigger @ jquery.min.js?ver=3.5.1:2
    (anonymous) @ jquery.min.js?ver=3.5.1:2
    each @ jquery.min.js?ver=3.5.1:2
    each @ jquery.min.js?ver=3.5.1:2
    trigger @ jquery.min.js?ver=3.5.1:2
    init @ frontend.min.js?ver=3.2.5:2
    initFrontend @ editor.min.js?ver=3.2.5:2
    onPreviewLoaded @ editor.min.js?ver=3.2.5:2
    onPreviewLoaded @ editor.min.js?ver=3.2.5:2
    dispatch @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2
    v.handle @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2
    load (async)
    add @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2
    s.event.add @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:5
    (anonymous) @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2
    each @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2
    ke @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2
    on @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2
    initPreview @ editor.min.js?ver=3.2.5:2
    onStart @ editor.min.js?ver=3.2.5:2
    onStart @ editor.min.js?ver=3.2.5:2
    (anonymous) @ backbone.marionette.min.js?ver=2.4.5.e1:24
    f.triggerMethod @ backbone.marionette.min.js?ver=2.4.5.e1:24
    start @ backbone.marionette.min.js?ver=2.4.5.e1:25
    13021 @ editor.min.js?ver=3.2.5:2
    __webpack_require__ @ editor.min.js?ver=3.2.5:2
    (anonymous) @ editor.min.js?ver=3.2.5:2
    (anonymous) @ editor.min.js?ver=3.2.5:2
    common.min.js?ver=3.2.5:2 Uncaught ReferenceError: originalEvent is not defined
        at onError (common.min.js?ver=3.2.5:2)
        at dispatch (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2)
        at v.handle (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,underscore,backbone,jquery-ui-core,jquery-ui-mouse,jquery-ui-draggable,wp-api-request&ver=5.7.2:2)
    Private
    Amir Rather Support Team
    This reply has been marked as private.
    Private
    TED THOMAS
    This reply has been marked as private.
    Tatyana Hutsol Support Team

    Hello,

     

    Could you provide FTP credentials in the private reply for investigation?

     

    Regards.

    Private
    TED THOMAS
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi Ted,

    I just raised a bug report for this and one of our developers would check and provide a fix for it very soon. I will update you here. It may take up to 48 hours until they can bring a tested and working fix. Thanks for being patient.

    Bests

    Private
    TED THOMAS
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi Ted,

    I applied a fix that I received from our developers, but in order to make sure that it’s working, you need to make sure this file is not cached on your browser:

    https://staging.tedthomas.com/wp-content/plugins/jupiterx-core/includes/extensions/raven/assets/js/frontend.min.js

    So, open it once and then do a hard reload and then open Elementor on your cartflows pages. The ultimate fix will be applied to the theme very soon.

    Please let me know if there are any further issues.

    Bests

    Private
    TED THOMAS
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

     

    Let us know if any assistance is needed.

    Regards.

    Private
    TED THOMAS
    This reply has been marked as private.
    Nodari Support Team

    Hey there

    This problem can be fixed by this css code:

    .raven-nav-menu li.menu-item:hover ul.sub-menu {
        display: block !important;
    }

    Add this code in the Appearance > Customize > Additional CSS and it will be fixed

Viewing 12 posts - 1 through 12 (of 12 total)
You must be logged in to reply to this topic.
Login