#78012 Langauge switcher not visible in Toolbar

Landing Forums Jupiter WordPress Theme Langauge switcher not visible in Toolbar

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • Wesley Rdam

    Hello,

    I’ve a website made with Jupiter and WPML but the language switcher is not added to the toolbar. Trying this with a shortcode of WPML but that not working.

    Can you please check this for me?

    Language need to be like this: NL | EN

    Amir Rather Support Team

    Hi There

    The site isn’t working at the moment, it flags the database error see https://prnt.sc/u5xz6r

    Did anything change?

    Regards

    Wesley Rdam

    Hi its up and running but still like to know πŸ™‚

    Private
    Nodari Support Team
    This reply has been marked as private.
    Wesley Rdam
    Private
    Tatyana Hutsol Support Team
    This reply has been marked as private.
    Private
    Wesley Rdam
    This reply has been marked as private.
    Nodari Support Team

    Hello Wesley

    Sorry but this method to add the shortcode of language switcher “[wpml_language_selector_widget]Languages” in the tagline place will not work because the tagline can accept only HTML tags and not shortcodes, in this case, you may try to add HTML of language switcher in the toolbar, but this will require some custom work. Alternatively you language switcher can be added in the default menu form the WPML settings page, you can add it in the current menu as a language switcher flags at the right side of the menu

    Hope this helps πŸ™‚

    Wesley Rdam

    No its doesn’t, I should be able to add the switch in the toolbar .. ?

    Tatyana Hutsol Support Team

    Hello,

     

    The languages bar is added automatically when a multilingual plugin is active. It’s present in the toolbar, but hidden under your logo https://take.ms/evICZ .

    I added this code in Theme Options > Advanced > Custom CSS to move the languages navbar to the right https://take.ms/3RcbX :

    .mk-language-nav {
    float: right;
    }

    but the languages dropdown isn’t shown because of your custom css code https://take.ms/PTSrJ . You need remove z-index from there to get the languages shown.

     

    If you want to show the switcher like this:

    https://take.ms/gYUtw

    add this css code:

    .mk-language-navigation li a {
    min-width: 60px !important;
    }
    
    .mk-language-nav>a {
    display: none;
    }
    
    .mk-language-navigation {
    display: flex;
    }
    
    .mk-language-nav-sub {
    background-color: transparent !important;
    border: none !important;
    }
    
    .mk-language-nav-sub-wrapper {
    display: inline-block !important;
    top: 0 !important;
    left: auto !important;
    right: 0;
    }

     

    Thank you.

    Regards.

    Wesley Rdam

    Thankyou very much!

    Private
    Tatyana Hutsol Support Team
    This reply has been marked as private.
    Wesley Rdam

    One more question, how can I set the flags at the right of the tagline. I know a little PHP so if you give me filename I have to change, just changes this order but that doesn’t do anything.

    Nodari Support Team

    Hey there

    In this case you dont need a PHP to change position, it can be fixed by this custom css:

    span.mk-header-tagline {
        right: 167px !important;
        position: absolute;
    }

    let me know if it worked πŸ™‚

    Wesley Rdam

    Perfect, thankyou!

    Wesley Rdam

    Do you also have a CSS trick to remove the hover background color ?

    Tatyana Hutsol Support Team

    Hello,

     

    Please add this css code:

    .mk-language-navigation li a:hover {
    background-color: transparent;
    }

     

    Regards.

Viewing 17 posts - 1 through 17 (of 17 total)
You must be logged in to reply to this topic. Login