#135129 Mega menu container is outside of the container

Landing Forums JupiterX WordPress Theme Mega menu container is outside of the container

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Leelnj

    Hi i have finally got the megamenu to display full width.The mega menu (.jet-mega-menu-mega-container__inner) is displaying full width and i have based the Mega Container Width Type on the header section that the menu is housed in ( I have also tried it on section that the menu is housed in eg #mega). It seems that the mega menu container (.jet-mega-menu-mega-container) is keeping relative to the menu and therefore spans out of my header container causing scroll bars. I have done a quick video showing you the issue . https://soapbox.wistia.com/videos/KuE4zRIjnM.

    You will need to log in to access the site as its in maintenance mode.

    if you go to the home page you will see the issue on the home and services menu. I have also created a page with no styling as well which shows the issue

    Amir Rather Support Team

    Hello There

    I see the issue, I have one question first though.

    “I have based the Mega Container Width Type on the header section that the menu is housed”

    How did you do that, please describe the steps you took?

    Regards

    Leelnj

    within the header template there is a mega menu. withing the mega menu setting there is a mega menu width selector. U can set a selector to follow from there

    https://i.imgur.com/LxQZoTN.png

    Mohsin Al-Rabieai Support Team

    Hi there,

    We have reported this as a bug to Crockoblock. Soon they will fix it on their product. Thanks for your report. Meanwhile, I wrote this CSS in Customizer -> Additional CSS to fix it:

    .jet-mega-menu.jet-mega-menu--layout-horizontal .jet-mega-menu-mega-container {
        left: calc(var(--jmm-submenu-delta-x-offset, - 100%));
    }
    
    .jet-mega-menu.jet-mega-menu--layout-horizontal .jet-mega-menu-mega-container__inner {
        -webkit-transform: translateX(calc(var(--jmm-submenu-width, 100%) + var(--jmm-submenu-delta-x-offset, 100%) , 0));
        -ms-transform: translateX(calc(var(--jmm-submenu-width, 100%) + var(--jmm-submenu-delta-x-offset, 100%) , 0));
        transform: translateX(calc(var(--jmm-submenu-width, 100%) + var(--jmm-submenu-delta-x-offset, 100%) , 0));
    
    }

    Hope it helps ūüôā

    Leelnj

    hello this is still not working. If you visit https://testing.secureyourticket.com/ you will see its still going off screen

    Mohsin Al-Rabieai Support Team

    Hi Leelnj,

    Sorry for the inconvenience. While Crockoblock team is still investigating this issue, we came to the understanding that this is a bug when the “Revamp Menu” option is active in the Crockoblock -> Jet Plugins settings -> Jet Menu. I settled your mega menu options exactly like our demo here:

    And the issue is now resolved. I recommend you to keep this setting for now and change the style of your mega menu through the global settings of Jet Menu until the bug get’s resolved by the Crockoblock team. Can you check and confirm that you can keep these changes?

    Bests

Viewing 6 posts - 1 through 6 (of 6 total)
You must be logged in to reply to this topic.
Login