#46715 My website loads very slow (10-30) sec on some iPhones (only some)

Landing Forums JupiterX WordPress Theme My website loads very slow (10-30) sec on some iPhones (only some)

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • Hedinn Hendriksson

    I cant figure out why but my websites loading time is horrible. specially on iOS mobile. It gets stuck on the loading logo for all from 10-30 or even more seconds.

    On a Mac Book, iMac or Android, this problem does not occur. But it does on some Ipads. It DOES load slow on android but much much faster.

    The page is set to show a video if the screen is large like a pc, but only an image if its a phone.

    Can anyone take a look for me?

     

    Also all tips on how I can speed up the site are very welcome.

     

    I have a geek package from Siteground so there should be enough resources.

    For anyone who wants to test the url is https://www.pickmeup.is

    Regards, Hedinn

    Tatyana Hutsol Support Team

    Hello,

     

    As I see you’re using very old theme version.

    Please update it via FTP to 6.4.1 version following this instruction:

    https://themes.artbees.net/docs/updating-theme-child-theme/ (read the part “Updating theme via FTP”)

    At first deactivate WPBakery plugin, update the theme, install Jupiter Donut plugin (required in the new version) via Jupiter > Control Panel > Required Plugins (or via Appearance > Install Plugins), then activate and update WPBakery Page Builder plugin via Appearance > Install Plugins.

    After that the loading speed should be increased.

    Thank you.

    Regards.

Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.
Login