#137643 Not Receiving Emails from Contact Us Form to Google Workspace Email

Landing Forums JupiterX WordPress Theme Not Receiving Emails from Contact Us Form to Google Workspace Email

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • haider-ce523607

    Hi,

    We were using VentraIP (Hosting Service) emails which are created using CPanel for Milestone Tix (www.milestonetix.com.au). We switched our emails to Google workspace almost a month back for Milestone Tix. Our website’s contact us page is https://milestonetix.com.au/contact/

    Once a user fills the form on the Contact Us page, the email with all the information on the form is forwarded to [email protected] and two other emails ([email protected] and [email protected]) as well.

    For some reason, the email is not being received directly on [email protected], while the same email is being received on [email protected] and [email protected]

    Please note that [email protected] and [email protected] are also on Google Workspace and only [email protected] is in the email on cpanel of VentraIP. We use Google Workspace for both milestonecreative.com.au (Based on Qode Interactive Bridge Theme) and milestonetix.com.au (Based on JupiterX).

    We did the following testing on our end:

    1. Use a different plugin for contact us form. However, the issue persists.
    2. Use two different emails ([email protected] and [email protected]) to see whether they receive email from the form or not, and they definitely receive it. [email protected] has the same scenario as of [email protected] (Both are on Google Workspace and CPanel). But at the same time, the email is not received in the Google Workspace one, but it is received on the VentraIP Cpanel Email.

    We also talked to Google Support and VentraIP support and both of them said that this issue is with the theme. They mentioned local delivery/remote delivery settings for it. So could you please update the settings or share a part of code with us, so that we can receive the emails that are sent through the Contact Us page of Milestone Tix.

    P.s. We receive all other emails fine in our inbox (Google Workspace). The issue is only related to the Contact Us page of our website and the receiving of emails from it to the Cpanel Email of [email protected]

    Nodari Support Team

    Hi Haider

    Thanks for the question,
    First of all, I want to let you know that you are using the Elementor form widget, it’s not designed by us, and it’s better to contact Elementor support since this is directly related to their product, you will have exact same problem on any WordPress theme.
    I also want to add some extra information, if the form is working for some Emails and not working for others, this means its working and you have a problem somewhere else, I would recommend checking to host support and email setup,
    Usually, Emails with domains have this problem and an effective way to fix it is by installing the SMTP plugin, it can easily fix this problem

    Let me know if you still have any related questions, but you definitely need to contact Elementor support

    Regards

    haider-ce523607

    Hi,

    Thank you for your response.

    We tried the WP Mail SMTP plugin and it resolved our issue. We connected it with Google Email API through Google Cloud Console.

    Thank you for your guidance.

    Nodari Support Team

    Raylly nice to hear that ūüėä

    Feel free to contact us again

    Regards

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.
Login