#94625 PHP 7.4 update breaking because of WPBaker

Landing Forums Jupiter WordPress Theme PHP 7.4 update breaking because of WPBaker

Viewing 26 posts - 1 through 26 (of 26 total)
  • Author
    Posts
  • Kelsey Grant

    Hey I’m trying to update my site to PHP 7.4 but WPBaker is breaking the site.

    See the error log on my standing site | Staging site: https://staging.kgrantarts.com/

    “Fatal error: [snuffleupagus][disabled_function] Aborted execution on call of the function ‘require_once’ in /home/kgrantar/staging.kgrantarts.com/wp-content/plugins/js_composer_theme/include/classes/core/class-vc-manager.php on line 326
    There has been a critical error on your website.

    Learn more about debugging in WordPress.”

    Danish Iqbal Support Team

    Hello Kelsey,

     

    Could you please share the WP Login details and FTP details in a private reply so that I can check out the issue?

     

    Regards.

    Private
    Kelsey Grant
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

    Thank you for the provided information, but as you got the error on a staging site then we need wp-admin and FTP access to it, not to the live one.

    Looking forward to your reply.

     

    Regards.

     

    Private
    Kelsey Grant
    This reply has been marked as private.
    Private
    Alexander Hutsol Support Team
    This reply has been marked as private.
    Private
    Kelsey Grant
    This reply has been marked as private.
    Tatyana Hutsol Support Team

    Hello,

     

    Sorry for a long delay.

    Please contact your hosting provider support and ask them to to activate the extension “snuffleupagus” on the server. After that check the staging site.

    Looking forward to your reply.

    Regards.

    Private
    Kelsey Grant
    This reply has been marked as private.
    Tatyana Hutsol Support Team

    Hello,

     

    Please also ask your hosting provider support to enable allow_url_fopen on the server.

    Let us know the result.

    Regards.

    Private
    Kelsey Grant
    This reply has been marked as private.
    Danish Iqbal Support Team

    Hello Kelsey,

     

    I tried to debug this issue a lot but it seems this issue is related to the server rather than the WordPress or the theme. It seems like your server has disabled the PHP function curl_setopt. Could you please contact your service provider and ask them to ensure that the function curl_setopt is not disabled and is working fine?

    Also, a similar issue has been reported to the WordPress support and this is what they have to say https://core.trac.wordpress.org/ticket/50748

    Let me know what the server guys replied.

     

    Regards.

    • This reply was modified 2 months, 2 weeks ago by Danish Iqbal.
    Private
    Kelsey Grant
    This reply has been marked as private.
    Danish Iqbal Support Team

    Hello Kelsey,

     

    No, that error is showing because I disabled all the plugins and that’s why the WPBakery error is not showing for now.

    That said, as you can see, the error says “Aborted execution on call of the function ‘curl_setopt’“, this means that the server has blocked the curl_setopt from executing. It seems like there are some security limits on your server that is blocking a vast majority of the functions from working. Note that this is neither a WordPress issue nor a theme issue. This issue needs to be resolved on the server.

    Also, this issue has already been asked on the WordPress support forums https://core.trac.wordpress.org/ticket/50748 and even they are of the opinion that this is a server issue rather than the WordPress issue.

    Please contact your service provider and ask them to resolve this as this looks like a server issue. Alternatively, you can ask them to activate any other PHP version instead of 7.4 and see if that helps.

     

    Regards.

    Private
    Kelsey Grant
    This reply has been marked as private.
    Danish Iqbal Support Team

    Hello Kelsey,

     

    Modifying the code in the core WordPress files is not a solution for this issue. Only modifying 1 file will not help because the error will continue to show for the rest of the files that are using the same or similar functions.

    After you modified the file, the site is now showing an error for the WPBakery page builder. For the test, I disabled all the plugins but again the site is showing the cURL error:

    Fatal error: [snuffleupagus][disabled_function] Aborted execution on call of the function 'curl_setopt', because its argument '$option' content (81) matched the rule 'Please don't turn CURLOPT_SSL_VERIFYHOST off.' in /wp-includes/Requests/Transport/cURL.php on line 150

    My point is, the site will continue to show many errors and modifying all the files is not a solution. Also, the issue is not about whether the extensions/modules like cURL is enabled or not. The issue is that even after these extensions/modules are enabled/installed, the server is blocking the process of these functions.

     

    The solution is simple, you will have to contact your service provider and tell them about this issue. Somehow, they have some security on the server that is blocking all these functions from working. Alternatively, you can also ask them to at least downgrade the PHP version to 7.3 and see if that helps.

     

    Regards.

    Private
    Kelsey Grant
    This reply has been marked as private.
    Danish Iqbal Support Team

    Hello Kelsey,

     

    Glad you figured out the PHP issue 🙂

     

    About the grid issue, it seems like the Post Masonry Grid element of WPBakery has some problem or is not fully compatible. This issue needs debugging, it could be a plugin issue or a cache issue.

    If you want you can instead use the Blog element to show the posts that comes with the Jupiter theme.

     

    Regards.

    Kelsey Grant

    “This issue needs debugging, it could be a plugin issue or a cache issue.”

    Does this mean it’s a known issue with the Jupiter theme? OR should I make a staging site that we can try debugging for my specific site?

    I played around with the blog element setting but the display isn’t as nice as what I had set up and it doesn’t meet the functionality needs. I really need to the Post Masonry Grid to work.

    Danish Iqbal Support Team

    Hello Kelsey,

     

    It’s not a known issue as of now, I said that because the Post Grid works and shows fine when you are logged into WordPress which means it’s most probably a cache issue.

    Yes, I think it’s better to make a staging site so that I can debug without worrying.

    Also, could you please tell me which hosting service are you using? And do you by any chance have cache service installed on the hosting like CloudFlare?

     

    Regards.

     

    Private
    Kelsey Grant
    This reply has been marked as private.
    Danish Iqbal Support Team

    Hello Kelsey,

     

    I actually cleared the Litespeed cache and it seems to be working now. Can you check the staging site now? Please clear your browser cache before you check it or check using a browser on which you have never checked it before.

     

    Also, I checked your plugins and found that you are using the original version of the WPBakery. It’s better if you use the Artbees modified version of WPBakery that is fully compatible with the theme.

    To install that, please delete the original version first and then go to Jupiter -> Control Panel -> Required Plugins and install the WPbakery Page Builder (Modified).

     

    Regards.

    Kelsey Grant

    I cleared the cache on the staging & live site and was able to get it to work temporarily too. However, now a few days later is back to not loading on both sites.

    I also updated the WPBakery to the one you specified on the staging and live site.

    Danish Iqbal Support Team

    Hello Kelsey,

     

    In that case, it looks like LiteSpeed cache is triggering this issue and the solution is to either keep on clearing the cache or disable the LiteSpeed cache plugin. You can use Autoptimize or WP Rocket cache plugin instead.

     

    Regards.

     

    Kelsey Grant

    Thank you seems to be working now

    Tatyana Hutsol Support Team

    You’re welcome!

    Regards.

Viewing 26 posts - 1 through 26 (of 26 total)
You must be logged in to reply to this topic. Login