#127176 Plugin wp-custom-area not attaching files

Landing Forums Jupiter WordPress Theme Plugin wp-custom-area not attaching files

Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • Alejandra Hoffman

    Hi

    We bought wp-customer-area plugin

    https://wp-customerarea.com/product/wpca-enhanced-files/

    And it doesn’t work with Jupiter (does nor save attached files -see image-).

    When we change the theme from Jupiter to

    <b>Twenty Seventeen</b>

    It works

    I attached an image with this working (with <b>Twenty Seventeen theme)</b>

    When we activate Jupiter Theme, and we update the custom file post (cuar_private_file), -> the attached files disappears, leaving this section void.

    Please our customer need to have the Jupiter Theme with the wp-customer-area plugin working

     

    Kind Regards

     

     

     

     

     

    Alexander Hutsol Support Team

    Hello,

     

    Please provide FTP and WP Dashboard credentials in the private reply.

    Also share the page URL where the files should be added.

     

    Regards.

    Private
    Alejandra Hoffman
    This reply has been marked as private.
    Tatyana Hutsol Support Team

    Hello,

     

    I tried to upload the file with Twenty Twenty One theme activated, and then checked it with Jupiter.

    The file was there https://prnt.sc/1gmv3eg .

    Could you clarify the steps to replicate the issue?

     

    Regards.

    Alejandra Hoffman

    Hi

    When you update the Post, the file (with Jupiter theme activated),  the attached files dissapears

    I had attached 2 images (step-1 & step-2) and the file that does not work 000 prueba PDF.pdf<i class=”fas fa-check ml-2 text-success”></i>

     

    Kind Regards

    Tatyana Hutsol Support Team

    Hello,

     

    I uploaded the file, updated the post and the file was still there https://prnt.sc/1h067jg .

    Am I doing anything incorrectly?

    Can you record the video so I can see all your actions?

     

    Regards.

     

    Private
    Alejandra Hoffman
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

     

    I tried to upload the file and updated the page and the file was saved.

    Please check my video:

    https://www.dropbox.com/s/t2cffmstcqi1f9v/file_upload.mp4?dl=0

    Unfortunately I can’t replicate the issue.

    Can you also check via Incognito mode of your browser?

    Also try on another computer.

     

    Regards.

    Private
    Alejandra Hoffman
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi Alejandra,

    I was able to see this issue after my colleague asked me to check this. I realized that sometimes it is happening and sometimes not. Anyway, I updated the theme and jupiter related plugins. The issue seems to be resolved. Can you confirm this, please?

    Bests

    Alejandra Hoffman

    Thank  you for the update, but it is NOT working at  the same environment conditions

    mac OSX mojave 10.14.6

    Chrome incognito mode

     

    Kind Regards

    Mohsin Al-Rabieai Support Team

    It’s so strange. Right now, I can not see it anymore with the exact same device. May I ask you to try another browser? You should be able to see the attachment on this test post:

    http://pre.iplangestion.com/wp-admin/post.php?post=17342&action=edit

    I did multiple updates, added files, remove them, updated the post, title, and everything else, and couldn’t see the issue anymore. Maybe it’s one of your browser extensions that is doing such a thing in your client? Can you try another device, please?

    Alejandra Hoffman

    Hi

     

    I tried with PC intel w 10

    Kind a random results. Some files works, some not.

     

    I keep trying

    Tatyana Hutsol Support Team

    Hello,

     

    Let us know if further assistance is needed.

     

    Regards.

    Alejandra Hoffman

    Yes it is not working with Jupiter theme

    Private
    Alexander Hutsol Support Team
    This reply has been marked as private.
    Alejandra Hoffman

    Hi

     

    I see the files. But when i tried to upload the file (000 prueba PDF.pdf) with Safari or Chrome browser and update the Post File, it is not working, it does not appears in the list file.

    Mohsin Al-Rabieai Support Team

    Hi Alejandra,

    Sorry, this is taking too long. Since we clearly not being able to reproduce this issue, we need your help in debugging this. I know you already shared some info and mentioned that this issue is not happening with the other themes. But since you mentioned that this is happening sometimes and sometimes not, we first need to make sure it’s a theme issue. I want to kindly ask you to switch to Twenty Twenty or any WordPress standard theme, deactivate Jupiter Core and Jupiter Donut plugins and try uploading the PDF file with the same name multiple times on multiple devices. It might be that the issue was not happening on the time you checked it with another theme, so before everything let’s make sure about it.

    In case it was happening with the other theme as well, it is most probably an issue with the server that needs to be taking care of by your web host support. In case it was not happening by the theme at all, let’s isolate it a bit more to find what can cause it. So, in this case, please deactivate Jupiter Donut and WPbakery Modified version plugins and try again multiple times. In case it was not happening after that, the issue is inside one of these plugins.

    Generally, in case we could make sure that this is happening only with the Jupiter theme, it’s better to have a live session together and I direct you by commenting on different sections on the theme core files and we test it together. Unfortunately, this is all because we are not able to replicate it on our side. So we need your help with this. Thanks for your understanding.

    Bests

    Alejandra Hoffman

    Hi Mohsin, you are welcome

    I will record a video showing the issue.

    • Step 1 with Jupiter theme activated -> KO
    • Step 2 with Twenty Twenty activated -> OK

     

    Kind Regards

    Private
    Alejandra Hoffman
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi Alejandra,

    It was trully helpful. Thanks. I was able to replicate the issue on my local machine and do a massive debugging. And finally could narrow down the issue to this function in jupiter/framework/functions/general-functions.php:

    /*
     * To remove accents from the name of uploaded files
     * Thanks to: https://goo.gl/h2tYrZ
     */
    if ( ! function_exists( 'mk_sanitize_file_uploads' ) ) {
    
    	function mk_sanitize_file_uploads( $file ) {
    		$file['name'] = sanitize_file_name( $file['name'] );
    		$file['name'] = preg_replace( '/[^a-zA-Z0-9\_\-\.]/', '', $file['name'] );
    		$file['name'] = strtolower( $file['name'] );
    		add_filter( 'sanitize_file_name', 'remove_accents' );
    
    		return $file;
    	}
    	add_filter( 'wp_handle_upload_prefilter', 'mk_sanitize_file_uploads' );
    
    }

    I removed this function and the issue was resolved on my local machine. However, your FTP doesn’t have editing permissions. I wanted to add this line to your child theme’s functions.php file but looks like only you can do it.
    Please add this piece of code into jupiter-child/functions.php and see if that will resolve the issue.

    add_action('init', function(){
    	remove_filter('wp_handle_upload_prefilter', 'mk_sanitize_file_uploads',10 , 1);
    
    }, 10);

    Hope it helps 🙂

    Alejandra Hoffman

    Hi Mohsin

     

    I applied your solution and it seems it works.

     

    I will keep trying with other files, and will make a conclusion

     

    Thank you vary much

     

    Kind Regards

    Alexander Hutsol Support Team

    Hello,

     

    You’re welcome.

    Let us know if further assistance is needed.

     

    Regards.

Viewing 23 posts - 1 through 23 (of 23 total)
You must be logged in to reply to this topic.
Login