#131012 Raven Posts Carousel issue after latest updates

Landing Forums JupiterX WordPress Theme Raven Posts Carousel issue after latest updates

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • Aron Martinez

    The Raven Posts Carousel does no longer work properly after the latest updates (WP 5.8.1, Jupiter X 1.26, Elementro 3.4.3, Elementor Pro 3.4.1, Jupiter X Core 1.23.0). The carousel does no longer scroll and displays a single full-width (fixed) post instead of multiple posts on 3 columns as it should be. No errors or warnings are displayed in the console.

    After several attempts (disabling Elementor experiments, disabling caching plugins, switching to default WP Twenty-One theme, etc.) I got it back to work by downgrading the JupiterX Core plugin back to version 1.22.0.

    Given that it is a live website I cannot provide WP Admin access, but I am available for further infos and tests.

    Thank you in advance for your help and for providing a working update asap.

    Mohsin Al-Rabieai Support Team

    Hi Aron,

    Thanks for your report. I’ve been trying to reproduce this issue on two of my websites but unfortunately had no luck. I have the exact same versions of everything that you mentioned on both of them and yet can not see the issue. I tried it once in my local machine and an online test website here : https://tat.artbees.team/test-posts-carousel/ but had no chance to see the issue.

    Can you kindly save your elementor page content as a template and then export it from Elementor templates and attach it to your reply so I can import it on my local machine? It might be happening under a certain circumstance that I’m not aware of and it can be helpful if you provide such a file. Thank you very much for your collaboration.

    Bests

    Private
    Aron Martinez
    This reply has been marked as private.
    Private
    Mohsin Al-Rabieai Support Team
    This reply has been marked as private.
    Private
    Aron Martinez
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi Aron,

    I was able to log in to the staging website and then I realized that the issue is not happening when I’m logged in. I figured out it’s a caching issue so I checked the Swift Performance plugin settings and unchecked the “Asynch Loading” and “Merge Scripts” functions and the issue seems to be resolved. I believe Plugins and the theme are not comfortable with this caching plugin. We always recommend using WP Rocket, Autoptimize, and Fastest Cache. But we never tried Swift Performance cache so it might be having some incompatibilities or requires expertise to configure correctly.

    Hope it helps 🙂

    Best

    Aron Martinez

    Hi Mohsin,

    Thank you for your update. I had effectively tried completely disabling Swift performance as soon as I encounterd the issue (and the issue was persisting with Swift completely disabled), but I had not tried disabling only the single settings “Async Execute” and “Merge Scripts”.

    Thank you very much again for your help.

    Would you consider supporting also Swift Performance in the future? Until now, from my tests on various websites, it allowed for better performance, higher fine-tuning and less issues than other existing caching solutions (including WP Rocket and Autoptimize), as well as better pricing.

    Best,
    Aron

    Mohsin Al-Rabieai Support Team

    Hi Aron,

    I will raise a feature request for this, but I should also tell you that, even with the most compatible caching plugins, enabling Asynch load for JS files is dangerous on a WordPress website unless you know how it works. Most probably, even right now, the Swift Cache plugin is compatible with Jupiter X and all the plugins, however, you need to configure it correctly by getting advice from a performance expert or even Swift Performance support. Anyway, I will raise a feature request upon this and will add it to our backlog. Thanks for asking 🙂

    Bests

Viewing 8 posts - 1 through 8 (of 8 total)
You must be logged in to reply to this topic.
Login