#107161 Safari Auto Play Video

Landing Forums Jupiter WordPress Theme Safari Auto Play Video

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • Ben Clement

    Hi,
    i have put the shortcode Video Player on my startpage, it works fine but not on safari. The autoplay on safari browser does not work. Do you know how we can fix it?
    https://one80-medical.de/layout/

    Private
    Ben Clement
    This reply has been marked as private.
    Tatyana Hutsol Support Team

    Hello,

     

    I see that Autoplay doesn’t work in Chrome too.

    This issue is related to AutoPlay Policy Changes in Google https://developers.google.com/web/updates/2017/09/autoplay-policy-changes .

    The sound in the video should be disabled in order to get the autoplay functionality.

     

    Thank you for understanding.

    Regards.

    Ben Clement

    sorry this is crazy on my chrome browser the video plays with sound and in autoplay how can this be?
    Only in Safari browser it does not work!
    Is there another way to embed the video with music and autoplay?

    Danish Iqbal Support Team

    Hello Ben,

     

    Unfortunately, the Chrome browser has stopped the autoplay of videos if the video has sound.

    Regarding the video not auto-playing on the Safari browser, it requires a new attribute to be added to the video tag which is playsinline explained in this article https://developer.apple.com/documentation/webkit/delivering_video_content_for_safari

    This option is currently missing from the video element of the WPBakery.

     

    I checked your site and I see that you have changed the video on the homepage and now it has a button instead of autoplay. If you want, you can use the theme’s video element/shortcode and share the FTP details so that I can set the playsinline attribute for the video shortcode.

     

    Let me know what you think.

     

    Regards.

    Private
    Ben Clement
    This reply has been marked as private.
    Danish Iqbal Support Team

    Hello Ben,

     

    Okay, I added playsinline attribute to vc_video.php file present in /wp-content/plugins/jupiter-donut/includes/wpbakery/shortcodes/vc_video/ folder and also set the Video element settings to autoplay.

    The video is autoplaying now on safari mobile too. Be advised that this code will override when you update the Jupiter Donut plugin and you will have to add the code again.

    Please check it and let me know if you need more help.

     

    Regards.

    • This reply was modified 1 week, 2 days ago by Danish Iqbal.
    Ben Clement

    Thanks a lot it works really great!!

    Alexander Hutsol Support Team

    Hello,

    You are welcome.

    Feel free to create a new topic if you have any other questions.

     

    Regards.

Viewing 9 posts - 1 through 9 (of 9 total)
You must be logged in to reply to this topic. Login