#136699 Scroll to Bottom Arrow

Landing Forums Jupiter WordPress Theme Scroll to Bottom Arrow

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • Sean

    Just wondering: is it possible to have the Scroll to Bottom Arrow at the bottom of a section in Jupiter , move vertically up and down a bit, like the photos do at https://jupiter.artbees.net/shortcodes/moving-image/?

    I’ve actually tried to place an image through moving image at the bottom of each section (a downward arrow), but it’s almost impossible to place it correctly at the bottom, and I can’t create a link to the next section like the “Scroll to Bottom Arrow” automatically does.

    Anyway, is it possible to make the Scroll to Bottom Arrow move vertically up and down?  Thanks.

     

    Alexander Hutsol Support Team

    Hello,

    Please add this CSS code in Jupiter > Theme Options > Advanced > Custom CSS to achieve the mentioned effect:

    @-webkit-keyframes updown {
    0% { transform: translateY(0); }
    100% { transform: translateY(-10px); }
    }
    
    .mk-skip-to-next {
    animation: updown 1s infinite alternate;
    -webkit-animation: updown 1s infinite alternate;
    }

     

    Regards.

    Private
    Sean
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

    Please provide us with wp-admin login details to your site in the private reply https://prnt.sc/qr3w3e to check the issue.

    Thank you.

    Regards.

    Private
    Sean
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

    I tried to log in to your site dashboard with the login details you provided but, unfortunately, I got the “Login Incorrect” error message. Please check the login information and give us the correct one.

    Thank you.

     

    Regards.

    Private
    Sean
    This reply has been marked as private.
    Alexander Hutsol Support Team

    Hello,

    Thank you for the updated information.

    To increase the bouncing speed of the buttons change the time in the custom CSS code from 1s to 0.5s, so the code will be:

    .mk-skip-to-next {
    animation: updown 0.5s infinite alternate;
    -webkit-animation: updown 0.5s infinite alternate;
    }

     

    As for the extra space, it’s caused by the custom amination code. To fix it you can change the value from 76 to 86 in line 17603 in the wp-content/themes/jupiter/assets/js/core-scripts.6.10.0.js file https://i.imgur.com/UzgVzWU.png .

    Regarding the increasing the speed when the page moves down, it can be set in the same file in line 2475 https://i.imgur.com/I5RVnDG.png by changing the duration value, for example, to 700.

     

    Regards.

    Sean

    Thanks for much for this. I used to code in the Custom CSS to increase the speed of the bounce, which looks great.

    One thing about changing code in files: When I upgrade Jupiter to the next version, will I have to change this code again?

    Also, is there another way of changing this code with some custom CSS instead? Thanks again.

    Alexander Hutsol Support Team

    Hello,

    As for the changing code in the core-scripts.6.10.0.js file, after the theme update you’ll need to change the code again. Unfortunately, it can’t be changes via simple custom CSS code and requires extra coding, which is out of the support scope.

    For more customization you can send a request to WPDone service.

    Thank you for understanding.

     

    Regards.

    Private
    Sean
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi Sean,

    Would you please check it now? You needed to disable the Minify JS on Theme Options -> Advanced -> Speed Optimization and clear the site ground optimizer cache. I can see that the code is now changed on the combined version of the cached script. Please note that changing it from 76 to 86 won’t be that much visible as it’s a small modification.

    Bests

    Sean

    Hi Moshin. Thanks so much! That’s great. Can I ask, should I always keep the Minify JS Option OFF? Is there a benefit to that, and is it interfering with the minification on the SG Optimizer plugin and CloudFlare minification? Thanks again.

    Mohsin Al-Rabieai Support Team

    You can keep that option off since you are using the SG Optimizer. It causes no conflicts and using the theme’s minification won’t affect the performance since you are using another minification.

    Bests

Viewing 14 posts - 1 through 14 (of 14 total)
You must be logged in to reply to this topic.
Login