#133134 Shop grid

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • Willem Botha

    Hello Artbees

    I need your help, please.

    I am building my Shop landing page with JetWooBuilder. However, I am unable to have the Shop products, for Tablet, run in three columns (please see attached).

    This is the back-end URL to my template: http://puzhr.co.uk/dev/stylsho/wp-admin/post.php?post=536&action=elementor

    Please let me know how to fix this.

    Best regards,
    Willem

    Mohsin Al-Rabieai Support Team

    Hi Willem,

    As far as I understand, this is happening because the Jet Elements or Jet Woo Builder CSS files are not being added to the backend editor while you edit with Elementor. It works fine on the front end. The weird part is, I can not reproduce it on my local machine. Also if I deactivate the Jupiter X theme and Jupiter X Core plugins, the issue remains on your website. I’m not sure what could be wrong at the moment, but most probably it’s a conflict with Elementor and Jet Woo builder plugin that we are not aware of.

    Please note that we bundled the plugin Jet Woo Builder with our product, but it’s not one of our plugins and we have limited support on it since we don’t know how it exactly works. Since the same issue happens with another theme and the Jupiter X Core plugin, I’m afraid we can’t find out what is wrong with it. After hours of debugging and comparing with my local machine, I just know that the CSS files responsible for adding the number of columns in tablet and mobile are not being added to the backend editor, but still, work in the front end. It works asking for help from the Crockoblock community in this case:

    https://www.facebook.com/groups/CrocoblockCommunity/

    Thanks for your understanding.

    Bests

    Willem Botha

    Hello Mohsin

    Jupiter X bundles a plugin but your company does not fully understand how the plugin works? Really?

    Mohsin Al-Rabieai Support Team

    Hi Willem,

    Sorry but this issue clearly has nothing to do anything with the theme, not the Jupiter X Core plugin. If you switch to another theme and deactivate the Jupiter X Core, you will see that the issue remains. That’s the point. It is a third-party widget that comes in a plugin that we provided its license to be bundled with our product. If it encounters an issue that we know how to handle, we won’t hesitate to help for sure. I’ve been debugging this for more than 2 hours and couldn’t find any solution for it. That’s why I asked you to check this with the Crockoblock community (the authors of this plugin) since they are the authors of it and most probably had this reported before.

    Thanks for your understanding.

    Private
    Willem Botha
    This reply has been marked as private.
    Mohsin Al-Rabieai Support Team

    Hi Willem,

    Sorry, I think the whole issue is a misunderstanding here. Please see my attachment. Apparently, since you changed the default Elementor breakpoints, the content inside the viewport still works with the old breakpoints. If I manually change the viewport in Elementor Editor, the issue is not happening. Please check the video attached to this reply. You have set the Elementor Tablet breakpoint to 1400px, while it breaks in 768px in the Elementor editor. (Which is still an issue, but at least you can continue your project now).

    So, for now, you may need to change the viewport size in Elementor editor when editing a page. This would at least be a temporary workaround to resolve the issue and help you deliver your project.

    Again, I still believe that it’s not a theme issue. I tried everything I could including regenerating assets of Elementor, synching libraries, deactivating/activating the plugins. The only thing that I still didn’t try and requires hours of debugging is the database record checks which would be really time consuming. If this is the only chance that we can help you with, we won’t hesitate.

    Bests

    Willem Botha

    Hello Mohsin

    Thank you very much for looking into the problem so thoroughly and for your advice. I greatly appreciate it. I did not think that my breaking points would affect the shop grid.

    I can now carry on with the website build and meet my deadline!

    Best regards,
    Willem

    Mohsin Al-Rabieai Support Team

    Glad to hear that and thanks for your understanding. 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
You must be logged in to reply to this topic.
Login