#127172 SPEEDINDEX_OF_ZERO / error generating Lighthouse report after update

Landing Forums JupiterX WordPress Theme SPEEDINDEX_OF_ZERO / error generating Lighthouse report after update

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • X-06 Designs

    Hello Artbees team,

    it seems that after updating all my plugins (like Elementor and ACF) to the latest version, Pagespeed Insights and GTmetrix can’t correctly analyize my page anymore. The errors are:

    • Google (on mobile and desktop analysis): SPEEDINDEX_OF_ZERO (I only get the error in German, but it says something like “Chrome did not capture screenshots during page load. Make sure that content is visible on the page, and then try running Lighthouse again.”)
    • GTmetrix: Analysis error – Error generating Lighthouse report

    I didn’t do much of a change on my website. The only thing I did, was updating all my themes and plugins and after that both analytics tools and also the build in Lighthouse functionality in Chrome doesn’t work anymore for the website.

    Please note: I didn’t update WordPress though. I still have version 5.7.2, because I’m waiting for you to confirm, that updating to 5.8 is safe.

     

    Would you please check this issue and help me solving it?

    Amir Rather Support Team

    Hi There

    This is because the site isn’t showing anything unless logged into the backend.

    Only when you log into the dashboard does the frontend show.

    Have you turned it off or this started happening after the update?

    Reagdrs

    X-06 Designs

    It seems that Slider Revolution deactivated itself after updating. Now the website shows the slider again, but Pagespeed Insights and GTMetrix are still not able to analyze the site.

    Can you already say, that Jupiter X (and the normal Jupiter theme) is compatible with WordPress 5.8?

    • This reply was modified 2 months, 3 weeks ago by X-06 Designs.
    • This reply was modified 2 months, 3 weeks ago by X-06 Designs.
    X-06 Designs

    Edit: The browser console shows this error, when I try to open the website without being logged in:

    Uncaught TypeError: Cannot read property ‘revolutionInit’ of undefined
    at Object.init (<anonymous>:13:13)
    at Object.window.RS_MODULES.callSliders (rs6.min.js?ver=6.5.5:38)
    at Object.window.RS_MODULES.checkMinimal (rs6.min.js?ver=6.5.5:38)
    at <anonymous>:69:71
    at RocketLazyLoadScripts._triggerDOMContentLoaded ((index):1)
    at async RocketLazyLoadScripts._loadEverythingNow ((index):1)

     

    I deleted Slider Revolution and reinstalled it, but the error is still there.

    Tatyana Hutsol Support Team

    Hello,

     

    The problem is related to the “WP Rocket” plugin.

    I disabled the option “Minify JS Files” in the WP Rocket settings and the site is loading fine, and gtmetrix results are generated.

    Please check.

     

    Regards.

    X-06 Designs

    This is strange, cause this worked before with the option activated. Thank you for helping me out!

    Speaking of caching plugins, which one is the most compatible with Jupiter X? My GTMetrix and Pagespeed ratings are unfortunately not great and I want to improve them. Maybe you have some best practices related to the Jupiter X theme that improve performance/ratings?

    Alexander Hutsol Support Team

    Hello,

     

    Did you check this article:

    https://themes.artbees.net/blog/speed-up-your-website-in-jupiter-x/ ?

    It has the instructions on how to speed up the site loading.

     

    Regards.

    X-06 Designs

    Yes, I went through all of this.

    Also what I experienced is, that the subtle grey background I added to my sub-pages initially loads “boxed” and after one or two seconds it changes to “full width” (see attached screenshots). This strange behaviour is also new.

    Alexander Hutsol Support Team

    Hello,

     

    To avoid this boxed layout while loading, add this code in Customizer > Additional CSS:

    .container {
    max-width: none !important;
    padding-right: 0px !important;
    padding-left: 0px !important;
    }

    Let us know the result.

    Regards.

    X-06 Designs

    After adding your code, the container gets pushed to the left side, instead of being full-width

    Mohsin Al-Rabieai Support Team

    Hi there,

    Sir, you just need to set your page as “Full Width”. Please check, I did it on your Services page. You may check it in incognito.

    Bests

    X-06 Designs

    This works, thank you very much. Do you have any additional suggestions according my performance problems? I still don’t get that good ratings in Pagespeed Insights and GTMetrix. I know these are not that relevant, but I want to be at least in an upper medium range.

    Mohsin Al-Rabieai Support Team

    Glad to hear that it helped 🙂

    May I ask which page are you trying to scan? I tested your services page and it has actually a good score:

    https://gtmetrix.com/reports/x06.de/fSWma4NV/

    Using a Cloudflare CDN will give you two A I believe.

    If you are testing this on your homepage, you won’t get much better results because of the big sliders. Premium, sliders are eating too much of the performance.

    Bests

    X-06 Designs

    Good to know. Is there a better alternative (other plugin or another technique with a similar visual style) you can recommend?

    Mohsin Al-Rabieai Support Team

    Well, not comparable to RV Slider at all, but maybe try Jet Elements Image Slider or Carousel though. Not sure if that helps. Also, maybe you can find some optimization tips on the RV slider community.

    Bests

Viewing 15 posts - 1 through 15 (of 15 total)
You must be logged in to reply to this topic.
Login