#126441 Vendors lessc parse error | Unable to Update Plugins without front end crashing

Landing Forums JupiterX WordPress Theme Vendors lessc parse error | Unable to Update Plugins without front end crashing

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • erika saracco

    Hi there,

    We’re having an issue updating our site.

    Any changes on the back end ( saving ) or updating any plugins result in the front end crashing.

    ‘There has been a critical error on this website.’ is what the front end users see.

    WP Admin is still accessible but the front end doesn’t load.

    The error we’re given is :

    PHP Fatal error: Uncaught Exception: parse error: failed at https: line: 12832 in /nas/content/live/interstatesta/wp-content/plugins/jupiterx-core/includes/compiler/vendors/lessc.php:3472

    Stack trace:
    #0 /nas/content/live/interstatesta/wp-content/plugins/jupiterx-core/includes/compiler/vendors/lessc.php(2285): jupiterx_lessc_parser->throwError()
    #1 /nas/content/live/interstatesta/wp-content/plugins/jupiterx-core/includes/compiler/vendors/lessc.php(1804): jupiterx_lessc_parser->parse(‘// Variables\n//…’)
    #2 /nas/content/live/interstatesta/wp-content/plugins/jupiterx-core/includes/compiler/class-compiler.php(580): JupiterX_Lessc->compile(‘// Variables\n//…’)
    #3 /nas/content/live/interstatesta/wp-content/plugins/jupiterx-core/includes/compiler/class-compiler.php(400): _JupiterX_Compiler->format_content(‘// Variables\n//…’)
    #4 /nas/content/live/interstatesta/wp-content/plugins/jupiterx-core/includes/compiler/class-compiler.php(95): _JupiterX_Compiler->combine_fragments()
    #5 /nas/content/live/interstatesta/wp-content/plugi in /nas/content/live/interstatesta/wp-content/plugins/jupiterx-core/includes/compiler/vendors/lessc.php on line 3472

    Any ideas on what could be causing this issue?

     

    Troubleshooting Steps:

    Updated all plugins

    Updated theme

    Updated all Theme Plugins

    Updated WordPress

    Regenerate assets from JupiterX panel

    The debug log is active to populate in the wp-content folder

    This is a staging site and any actions required to help in deducting the issue is fine.

    The site has been backed up

    Private
    Amir Rather Support Team
    This reply has been marked as private.
    erika saracco

    From the image it looks like you’re trying to connect to ‘sftp.wpengine.com’

    but the host should be: interstatesta.sftp.wpengine.com

    I just tested the credentials and they are working as provided.

    Could you please try again?

    thanks

    Tatyana Hutsol Support Team

    Hello,

     

    I see the problem is related to your child theme.

    When I disabled the functions.php file, the site loaded.

    So please check the code you added in this file.

     

    Regards.

    erika saracco

    I can confirm.

     

    When I remove the line:

    jupiterx_compiler_add_fragment( ‘jupiterx’, get_stylesheet_directory_uri() . ‘/assets/less/style.less’, ‘less’ );

     

    The issue goes away.

     

    the less file is empty.

     

    I’m guessing it has to do with the compiler issue from the logs that I mentioned earlier.

     

    Any ideas on what could be causing this?

     

     

     

     

    Tatyana Hutsol Support Team

    Hello,

     

    I have uncommented the line for investigation, checked the site and loaded fine even with that line active.

    Could you clear your browser cache and check the site again?

     

    Regards.

    erika saracco

    Cleared the cache resulted in no issue.

    Going into the customizer and then adding a css value. Save. This results in the Hard Error we’ve been seeing.

     

    To resolve this issue I comment out

    jupiterx_compiler_add_fragment( ‘jupiterx’, get_stylesheet_directory_uri() . ‘/assets/less/style.less’, ‘less’ );

     

    After I comment out the ‘add fragment’ the site re-appears.

     

     

    Tatyana Hutsol Support Team

    Hello,

     

    Did you change the wp-admin login credentials?

    I can’t log in now.

    Please provide the correct ones for further investigation.

     

    Regards.

Viewing 8 posts - 1 through 8 (of 8 total)
You must be logged in to reply to this topic.
Login