#135132 video on safari mobile not loading

Landing Forums Jupiter WordPress Theme video on safari mobile not loading

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • Sergio Torres

    Hi

    The video on the homepage can’t be seen on safari mobile. The file https://umapausadinamica.com/teste/wp-content/uploads/2021/11/design-sem-nome-_4_.webm doesn’t work on mobile safari but https://umapausadinamica.com/teste/wp-content/uploads/2021/11/video.mp4 works but when accessing the homepage not video is shown.

    Thank you

    Amir Rather Support Team

    Hello There

    “but https://umapausadinamica.com/teste/wp-content/uploads/2021/11/video.mp4 works but when accessing the homepage not video is shown.”

    I don’t understand this part of the question, I see it is shown here https://take.ms/JKGvO

    Regards

    Sergio Torres

    Hi. I asked the client to access the links on her mobile which has safari to see if she could see the video and it seems she can’t only see the webm version which is the one that loads when she sees this website on mobile mac. Thank you

    Mohsin Al-Rabieai Support Team

    Hi Sergio,

    You are right. It is a bug and happening due to the recent webkit updates. I reported it as a bug and modified your jupiter-donut plugin to fix it. The fix is to add `playsinline` attribute to the background videos when it supposed to play automatically. Two files needs to be modified:

    jupiter-donut/includes/wpbakery/shortcodes/vc_video/vc_video.php line 44:

    if ( 'true' == $muted && 'true' == $autoplay ) {
    $video_controls = ' muted';
    }

    Should be like this:

    if ( 'true' == $muted && 'true' == $autoplay ) {
    $video_controls = ' muted playsinline="" ';
    }

    And jupiter-donut/includes/wpbakery/shortcodes/mk_page_section/components/video-background.php line 27:

    <video poster="<?php echo esc_url( $poster_image ); ?>" muted="muted" preload="auto" <?php echo esc_attr( $loop ); ?> autoplay="true" style="opacity:0;">

    Should turn into this:

    <video poster="<?php echo esc_url( $poster_image ); ?>" playsinline="" muted="muted" preload="auto" <?php echo esc_attr( $loop ); ?> autoplay="true" style="opacity:0;">

    I checked the video on a real device afterwards and it was playing. Can you please check it on your end too?

    Hopefully, this fix will be included in the theme soon.

    Bests

    Sergio Torres

    Hi. It’s visible now. Can it be in loop also in mobile? Thank you

    Sergio Torres

    Sorry it seems it’s already in loop. Mistake of my client

    Sergio Torres

    client found a bug. in attachment in page https://umapausadinamica.com/teste/clientes/ in mobile. how to add line height in testimonials?

    Nodari Support Team

    Hi Sergio

    Those line heights can be adjusted by this code:

    /* Testimonial author */
    .mk-testimonial.avantgarde-style .mk-testimonial-author {
        line-height: 36px;
    }
    
    /* Testimonial */ 
    #testimonial_5 .mk-testimonial-quote {
        line-height: 29px;
    }

    Regards

    Sergio Torres

    Perfect. Thank you

    Alexander Hutsol Support Team

    Hello,

    You are welcome ūüôā

    Feel free to create a new topic if you have any other questions.

     

    Regards.

Viewing 10 posts - 1 through 10 (of 10 total)
You must be logged in to reply to this topic.
Login