#62271 Yoast breadcrumbs and Jupiter incompatibilities

Landing Forums Jupiter WordPress Theme Yoast breadcrumbs and Jupiter incompatibilities

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • Dipesh

    Hi,

    The shortcode to add Yoast breadcrumbs to pages is not working. Upon further examination, I could see that the option to enable breadcrumbs on Yoast was not showing.

    Changing the theme to 2020, enabling breadcrumbs and activating Jupiter theme did the trick.

    Wordpress, all plugins and Jupiter were up to date.

    My website is https://www.extremecanopy.com/

    Could you please check this?

    Dipesh

    FYI this is how the breadcrumbs option shows in current Jupiter

    Tatyana Hutsol Support Team

    Hello,

     

    Sorry for a delay.

    As I see the breadcrumbs are displayed https://take.ms/CsFir .

    Could you show a page where you are trying to add it and provide WP Dashboard credentials in the private reply?

     

    Looking forward to hearing from you.

    Regards.

    Sebastian Ouchev

    Everything is activated but the breadcrumbs are not working

    Sebastian Ouchev

    I added custom short code and it is not working okay… If I add breadcrum element in elementor it says : “Breadcrumbs are disabled in the Yoast SEOĀ Breadcrumbs Panel ” and they are not disablaed !

    Amir Rather Support Team

    Please try adding this [wpseo_breadcrumb] in a Shortcode Widget if you haven’t already?

    To see if it works? Please provide login details if it doesn’t.

    Waiting for your reply šŸ™‚

    Dipesh

    Hi,

    I’m sorry about the late reply. I was able to enable breadcrumbs by activating the WordPress 2020 theme. when Jupiter is enabled, no toggle shows to enable breadcrumbs. Furthermore, the breadcrumb schema is not showing on the markup tool.

    WordPress, plugins and Jupiter (6.5.5) theme are up to date.

    you can see an example of a pageĀ  in https://www.extreme-marquees.com.au/custom-printed-marquees/ and the markup results on https://search.google.com/test/rich-results?utm_campaign=sdtt&utm_medium=url&id=u9D-GAcVY9P9VCXK1DmQug

    Dipesh

    as an update, the issue with schema no showing was due to an incompatibility with the plugin “Schema & Structured Data for WP & AMP”. I have disabled it and schemas are showing again. Please note that the issue with Yoast breadcrumbs isstill happening.

    Alexander Hutsol Support Team

    Hello,

     

    I see the breadcrumbs are shown https://take.ms/AnTrX .

    Can you show a screenshot where they are missing and provide WP Dashboard credentials in the private reply?

     

    Thank you.

    Regards.

    Mark Anderson-Jones

    I also have this issue. The Enable Breadcrumbs toggle is missing from the Yoast settings.

    Here’s a screenshot of the toggle showing: Toggle showing >>

    Here’s how the settings look in WordPress with Jupiter: Screenshot from your own Yoast configuration documention >>

    Toggle is missing from your own documentation.

    The only way to enable breadcrumbs is to switch to a generic WordPress theme where the toggle is visible.

    Any changes made to Yoast settings will then disable the breadcrumbs again.

    Any clues as to what’s happening here? Conflict with Jupiter?

    Cheers, Mark

     

    Mark Anderson-Jones

    I’ve figured this out.

    This code in the Jupiter parent theme functions.php: add_theme_support( ‘yoast-seo-breadcrumbs’ ); is supposed to hide the toggle and enable the breadcrumbs by default. However it is only hiding the toggle and not enabling the breadcrumbs.

    Just add this to functions.php in the child theme:

    // Remove yoast theme support
    add_action( ‘after_setup_theme’, ‘disable_yoast_theme_support’, 11 );

    function disable_yoast_theme_support() {

    remove_theme_support( ‘yoast-seo-breadcrumbs’ );

    }

    Then the toggle shows and can be enabled and saved. Shortcodes work again and display the breadcrumbs…

    Tatyana Hutsol Support Team

    Hello @Mark,

     

    Thanks for sharing a solution!

    This is very helpful!

     

    Best regards.

    Alessandro

    I have tried this code but it gave me this errors:

     

    <b>Warning</b>: Use of undefined constant ā€˜after_setup_themeā€™ – assumed ‘ā€˜after_setup_themeā€™’ (this will throw an Error in a future version of PHP) inĀ <b>/home/sailing1/public_html/es.sailingmediterraneo.com/wp-content/themes/jupiter/functions.php</b>Ā on lineĀ <b>6</b>

    <b>Warning</b>: Use of undefined constant ā€˜disable_yoast_theme_supportā€™ – assumed ‘ā€˜disable_yoast_theme_supportā€™’ (this will throw an Error in a future version of PHP) inĀ <b>/home/sailing1/public_html/es.sailingmediterraneo.com/wp-content/themes/jupiter/functions.php</b>Ā on lineĀ <b>6</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/sailing1/public_html/es.sailingmediterraneo.com/wp-content/themes/jupiter/functions.php:6) inĀ <b>/home/sailing1/public_html/es.sailingmediterraneo.com/wp-includes/functions.php</b>Ā on lineĀ <b>6270</b>

    Tatyana Hutsol Support Team

    Hello @Alessandro,

     

    Those are just warnings, not the errors.

    You can disable them adding this code in the wp-config.php file before the line “Thatā€™s all, stop editing! Happy blogging.”:

    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_DISPLAY', false);

    Let us know the result.

    Regards.

Viewing 14 posts - 1 through 14 (of 14 total)
You must be logged in to reply to this topic. Login