Before Updating please read Migration Note!
Before upgrading to V5.0 make sure you server complies with WordPress environment requirements. We have been using some OOP technics and standards that are not present in legacy versions (e.g. v5.2.X, v5.3.X). Minimum required version is PHP V5.4+

  • New Feature : 4 More new Templates
  • New Feature : Woocommerce V2.5 Compatibility.
  • Improvement : RTL improvements
  • Improvement : Added PHP version check
  • Improvement : Global theme Preloader improvements
  • Improvement : Edge Slider & Vertical header improvements
  • Improvement : Added preloader to post pagination, portfolio sortable and portfolio ajax load
  • Improvement : Ajax Portfolio code enhancements
  • BugFix : WooCommerce product variable image not changing when options changed
  • BugFix : Flickr widget not working
  • BugFix : Fullscreen navigation css and reposnive fixes
  • BugFix : Main Navigation location for logged in users not working
  • BugFix : Contact form > website field is not covered in the email
  • BugFix : Pricing table button issues
  • BugFix : Photo Album fixes
  • BugFix : News Tab not working correctly
  • BugFix : Image shortcode caption has overflow out of the image
  • BugFix : Image Gallery shortcode color overlay option not working
  • BugFix : Contact form translation issues
  • BugFix : Side Dashboard burger icon & portfolio sortable bug
  • BugFix : Some issues with load more post_in, author and archive wrong categories.
  • BugFix : mk_get_attachment_id_from_url recoded to fix multiple issues in some servers
  • BugFix : Shape divider browser issues
  • BugFix : Page section / Background blend modes (luminosity effect) not working at safari browser
  • BugFix : Some other unlogged bug fixes